Maui Forums

Full Version: [Closed] - KWallet breaks with a simple logout/in.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
As per my earlier;

"...for me in 5.8.0 logouts are still no good compared to reboots, because sadly with a simple logout/in, KWallet breaks... it will not accept my password, hence all the programs relying on KWallet to supply their own passwords, fail. This is not a new fault, it's been this way since my 5.8.0 upgrade, but i forgot to..." ... create a dedicated thread for it, til now [coz the bug continues, & it's pretty annoying]. Everything is good again after a full reboot, but that is extremely disruptive. I would like KWallet to behave itself when i log out & in again, without having to instead reboot.
I guess maybe it isn't killed on logout (or closed).
That might be the root issue. I wonder just out of curiosity if you enter a tty terminal and login there (Ctrl+Alt+F1 for tty and Ctrl+Alt+F7 to go back on the graphical user interface) and execute a restart of the login manager (which restarts X basically and should close the wallet for good) helps.
You can restart it with the command sudo systemctl restart sddm
Thanks, but still no good. Ctrl+Alt+F1 did not produce tty, just a blank screen, though Ctrl+Alt+F7 did bring me back to my graphical session ok. Then whilst in the session, in Konsole i ran sudo systemctl restart sddm. As expected this did take me back to a new login screen, BUT... after logging in to the clean new session, KWallet was STILL broken / closed, & still rejected my password when i began using pgms whose credentials are stored in KWallet [it shouldn't even pop-up to ask me for password, as it's supposed to get my password from the login process, just like successfully occurs after a full reboot].

After the sequence summarised above, i clicked the tray Network Manager icon, to activate my VPN. Instead of doing so, it threw up this, & rejected my password:

I then tried to access KWallet from the Applications Menu, but:


PS -- I'll declare this, in case it's somehow relevant; my /home partition is encrypted, as per my original Ubiquity Installer setting [remember, we corresponded about this when i first began testing Maui, as your original installer in the ISO was faulty wrt encryption].
I needed, within the last 30', to logout/in, but exasperatingly this turned into yet another full reboot when, once again, after the logout/in kwallet was once again broken. Clearly this is an intractable problem, given the 100% failure rate i'm experiencing with it, & the erstwhile lack of notified solutions. Questions:

1. Is there likely to be a solution during the remaining life of Maui 1?

2. Has this been explicitly tested in Maui 2, & is it 100% reliable therein?
Did you enable Kwallet under the under the Plasma Services kcm as well as in the kwallet kcm?
I do believe that this may be causing your problem with this not sticking.
Thanks for your reply. Answer to both questions = Yes. Here's the pics [are any of my settings in either, wrong-looking to you?]:
Shouldn't one of those "close when" selections be activated, otherwise the wallet would be open all the time.
Oh? At the risk of sounding stupid, is it a bad thing for wallet to stay open when i'm using my pc? To experiment, i've now activated the 3rd option; "Close when last application stops using it". 

Interestingly, after reading your latest reply, i checked the system tray, expecting to see wallet listed there [given it should have opened(???) last time i rebooted], & was most surprised to find it's not there [& i am still actively using my Vivaldi-Snapshot browser, & VPN, two of the pgms linked to my wallet]. Odd! 

Logically, having made that setting change now [which TBH i can't see how will help the main problem of this thread], i should now retest via a logout/in. However, given my pessimistic expectation that it won't help, & that therefore post log-in when i run two of my things linked to kwallet [my VPN, & my browser], they'll get rejected [again] & i'll have to suffer the further disruption of yet another full reboot. I'll have to do this test another time...
Well, as i expected, the recent kwallet setting change did nothing to fix this annoying bug.

Furthermore, since my last post the Plasma 5.8.2 upgrade has occurred, but very disappointingly i've found that i STILL cannot do a simple logout/in [due to the kwallet breakage that ensues], so still every time i need to do a quick logout/in [eg, after making some relatively trivial UI aesthetic change via Settings], i have to instead do the longer & more disruptive full reboot.

Pls, is there nothing that can be done to resolve this?
Could it posibly be that you have the seesion set to use an empty session at login?

Login & Logout settings:
On Login you may choose one of three options on what should happen when you log into KDE:

Restore previous session:
If this option is checked, KDE will save your current session's state when you logout. KDE will restore your session on the next login, so you can continue to work with a desktop just like you left it.

Restore manually saved session:
Instead of restoring KDE to the state it was when you logged out last, it will be restored to a specific state that you have saved manually.

If this option is checked, the start menu offers an additional item Leave → Save Session.

Start with an empty session:
If you choose this option, KDE will never restore sessions that it has saved.
Pages: 1 2 3 4