Maui Forums
[Closed] - plasma-widget-volumewin7mixer [Tower] - Printable Version

+- Maui Forums (
+-- Forum: Maui Support (
+--- Forum: Plasma Desktop (
+--- Thread: [Closed] - plasma-widget-volumewin7mixer [Tower] (/showthread.php?tid=24323)

[Closed] - plasma-widget-volumewin7mixer [Tower] - kdemeoz - 16th March 2017

I have just upgraded my Lappy from 2.1 to 17.03, & it was an easy stress-free successful process.

Back on 5 March i also brought my Tower to 17.03, but it was via a clean install from the 17.03 ISO.

On both computers i now use & enjoy the new volume widget in the panel; plasma-widget-volumewin7mixer. However, whilst both look & work the same when left-clicked, there is an important difference in their right-click behaviour. On Lappy all is good, but on Tower there is a problem:

"Audio Volume Settings..."

"PulseAudio Control"

How can i repair these problems so that all aspects of the widget work as well on Tower as they do on Lappy, pls?

RE: plasma-widget-volumewin7mixer [Tower] - kdemeoz - 16th March 2017

Groan! Lappy has now gone the same way as Tower in this problem. The change occurred once i began playing some music. On both computers i use the PulseAudio graphic equaliser, per, which works really well... BUT i suspect that it might be the cause of the obliteration of those two widget settings popups. Does anyone know how to fix that pls?

RE: plasma-widget-volumewin7mixer [Tower] - leszek - 16th March 2017

Just a quick guessing. Did you restart your machine and the problem still occurs ?

And the main problem seems that the right click audio settings entries don't show up anything?

Quote:On both computers i use the PulseAudio graphic equaliser
Did the problem occur after installing this? Can you close or remove this to see if it fixes the issue.

RE: plasma-widget-volumewin7mixer [Tower] - kdemeoz - 18th March 2017

Yes, yes & yes, leszek

More info:

1. I have used the PA Equaliser on both my computers for several years, ie, long before Maui... from
2. For my recent clean-install of 17.03 on Tower, once that was complete i installed all my other preferred pgms, including this one. The changed behaviour of those applets occurs after Eq installation & operation.
3. For my recent 17.03 upgrade of Lappy, the PA Eq was already installed. As i described in my recent post, after upgrade but before i played any sound, the new SysTray plasma-widget-volumewin7mixer applets ALL behaved correctly. Like with Tower however, as soon as i then used any sound, those applets ["Audio Volume Settings..." & "PulseAudio Control"] broke per my recent pictures [but "Audio Volume (Win7 Mixer) Settings..." remains ok].
4. Today i upgraded two of my Maui 2.1 VMs to 17.03. Before upgrade neither of these had the PA Eq installed, & so post-installation [& reboot] the new plasma-widget-volumewin7mixer fully worked. I then installed the PA Eq into one of these VMs. To my amazement & confusion, it seems to still work fine with the plasma-widget-volumewin7mixer. That's a pity, as [expecting it to have also caused the problem] i had intended to try to fully remove it & all dependencies, to see if that then fixed plasma-widget-volumewin7mixer. Given it didn't break, there was no point proceeding.
5. In Tower & Lappy the sound quality is MUCH better with the PA Eq, so i do not wish to run either pc without it. I have not therefore tried removing it... even if that then restored the normal function of those two applets, it's too high a price to pay. It would have been nice if all components played nicely together...