Maui Forums

Full Version: calibre broken in synaptics
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

for some reason i can't install "calibre" on synaptics > "fix broken packages first".

any idea? i'd rather not use the terminal command given on the calibre website / use the latest version: it keeps on crashing, etc. The old version works just fine.

can you please help? thanks!
Can you try installing calibre from the terminal to get a proper error message.
~$ sudo apt-get install calibre
[sudo] password for weword:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
calibre : Depends: calibre-bin (>= 2.55.0+dfsg-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
And when you try to to also add calibre-bin to the apt-get install command?
a window pops up (sorry for some reason i can't find a screenshot app on maui - except "steam" asking me to create an account (?)) that says

"could not mark all packages for installation or upgrade

the following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the >Repositories< option under settings:

Depends: qtbase-abi-5-5-1
Depends: sip-api-11.2"

i looked into >Repositories< under Settings, and a whole list appears. I'm just not sure I should tick off each and every one of them...
Ah ok. So calibre is incompatible with the qtversion we provide. Neon from which we sync our qt version apparently did not rebuild calibre against that newer Qt version.
I suggest installing calibre then from the official website
sorry but why would calibre downloaded from the official website be any more compatible with maui than the 2.5.5. version you find on synaptic? please see my initial post.

is it an issue with kde? kubuntu 16.04 seems (at least on my machine) presents a similar problem: version 3.19.0 (from the website) appears to be buggy, crashes often, in short, unreliable, except that calibre downloaded via synaptic works perfectly.

any idea? thanks.
Quote:any idea? thanks.
If the version they provide on their website crashes and is buggy please report this to them.
As for getting the older version running you basically need to get this version then recompiled against the newer qt version.

apt-get source calibre
sudo apt-get install build-essential fakeroot debhelper devscripts
sudo apt-get build-dep calibre
cd <calibre-folder>
debuild -rfakeroot -us -uc

After that you should find the deb files for calibre and it should work fine hopefully.
many thanks leszek!

you're perfectly right about reporting to calibre re: their latest version.

I'm trying out your script, and get stuck at

"~$ sudo apt-get build-dep calibre
Reading package lists... Done
E: You must put some 'source' URIs in your sources.list"

sorry i'm not that linux-literate...what am I doing wrong?

"cd <calibre-folder>
bash: syntax error near unexpected token `newline"

do I need to create a "calibre folder" and name it "calibre folder" and put it somewhere? where?

thanks again!
Pages: 1 2